Back to overview
Degraded

Incident Report 9/2025

Dec 29, 2025 at 9:05pm UTC
Affected services
Explorer as a Service
Routescan

Resolved
Dec 29, 2025 at 9:15pm UTC

Type: Backend
Network: Mainnet
Description: Resolved

Created
Dec 29, 2025 at 9:05pm UTC

Type: Backend
Network: Mainnet
Description: Major slowdowns on website