Back to overview
Degraded
Incident Report 4/2025
Mar 27 at 03:00am CET
Affected services
Explorer as a Service
Resolved
Mar 27 at 06:00am CET
Type: Backend
Network: Mainnet and Testnet
Description: Solved
Affected services
Explorer as a Service
Created
Mar 27 at 03:00am CET
Type: Backend
Network: Mainnet and Testnet
Description: We are experiencing a block on C-Chain in transactions, log and internal ops.
Affected services
Explorer as a Service