Back to overview
Downtime

Incident Report 2/2025

Feb 11, 2025 at 3:00pm UTC
Affected services
Explorer as a Service
API
Routescan

Resolved
Feb 11, 2025 at 3:40pm UTC

Type: Frontend and Backend
Network: Mainnet and Testnet
Description: Solved but under review

Created
Feb 11, 2025 at 3:00pm UTC

Type: Frontend and Backend
Network: Mainnet and Testnet
Description: Service failure