Back to overview
Downtime
Incident Report 5/2024
Apr 23 at 10:20am CEST
Affected services
Explorer as a Service
Routescan
Resolved
Apr 23 at 10:30am CEST
Type: Frontend
Network: Testnet and Mainnet
Description: Typo frontend
Affected services
Routescan
Explorer as a Service
Created
Apr 23 at 10:20am CEST
Type: Frontend
Network: Testnet and Mainnet
Impact: The mainnet and testnet explorer were down.
Affected services
Routescan
Explorer as a Service